# Maintainer: Christoffer Müller Madsen <christoffer@guava.space>
pkgname=gworkspace
_pkgname=GWorkspace
pkgver=0.9.4
pkgrel=1
pkgdesc="The GNUstep Workspace"
arch=(i686 x86_64)
url="http://www.gnustep.org/experience/GWorkspace.html"
license=('GPL')
install=$pkgname.install
depends=(gnustep-base gnustep-gui gnustep-back)
makedepends=('gcc-objc'
             'gnustep-make')
provides=(gworkspace)
conflicts=(gworkspace)
replaces=(gworkspace.app-svn)
source=(ftp://ftp.gnustep.org/pub/gnustep/usr-apps/$pkgname-$pkgver.tar.gz)
md5sums=('406256f470781bc3be2670611276780f')

build() {
  cd "$srcdir/$pkgname-$pkgver"
  . /usr/share/GNUstep/Makefiles/GNUstep.sh
  ./configure
  make
}

package() {
  cd "$srcdir/$pkgname-$pkgver"
  make DESTDIR="$pkgdir/" install
  install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
    "$pkgdir/usr/share/applications/$_pkgname.desktop"
}